Home Forums Model Expert queries Class not in reference model

Home Forums Model Expert queries Class not in reference model

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #9503
    Slávek Rydval
    Participant

    Hello,

    I am playing with the Model Expert and went through the creating metamodel and a reference model. It is pretty simple: just a class with an association and an enumeration.

    When I try to check the source diagram (or any other), I get “Class not in reference” violation. Did I miss any step in the help?

    The source diagram:

    #9504
    eadocX Support
    Keymaster

    took me a while, but I finally found out what’s happening.
    In the meta-model, there is an extra space character in front of ‘Class’, so that it’s called
    ‘ Class’, which is the reason for the incorrect ‘class not found’.
    In the short-term, if you just remove the extra space from the meta-model, or the reference MM (or both) then all will be well. I will fix this error in the next release.
    I’ve checked, and it’s only ‘Class’ meta-types which do this – everything else seems fine. Probably a ‘funny’ from EA…

    #9505
    Slávek Rydval
    Participant

    Well, that’s it. Thanks for the solution.

    #9506
    eadocX Support
    Keymaster

    I checked in EA again, and the reason we have to do some strange things is that, when you create an element in EA, and give it a name of ‘Class’, then the name is set to blank. Error in the EA API

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.

Compare pricing and features

Choose the eaDocX edition that’s right for you and your team

Compare Pricing

Download a free trial

Take a free, no obligation, 30-day trial of eaDocX. Discover for yourself why it’s the world’s best-selling Enterprise Architect extension.

Download