Home Forums Model Expert queries Object reference not set to an instance of an obje

Home Forums Model Expert queries Object reference not set to an instance of an obje

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #9507
    J Cullen
    Participant

    I get the following error when running Model Expert.

    [code]************** Exception Text **************
    System.NullReferenceException: Object reference not set to an instance of an object.
    at Model_Expert.EARepository.makeInstanceMDEs(EAPackage p, ProfileGenerator pg)
    at Model_Expert.MXModelAnalyser.addInstanceClassifiers(EAPackage p, ProfileGenerator pg)
    at Model_Expert.MXModelAnalyser.runPackage(EAPackage analysisPackage, iNotifyForm parentWindow)
    at Model_Expert.MXModelAnalyser.run(EAPackage analysisPackage, iNotifyForm parentToBeNotified)
    at Model_Expert.ModelAnalyserController.run()
    at Model_Expert.frmMXAnalyse.btStart_Click(Object sender, EventArgs e)
    at System.Windows.Forms.Control.OnClick(EventArgs e)
    at System.Windows.Forms.Button.OnClick(EventArgs e)
    at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
    at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
    at System.Windows.Forms.Control.WndProc(Message& m)
    at System.Windows.Forms.ButtonBase.WndProc(Message& m)
    at System.Windows.Forms.Button.WndProc(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
    at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
    [/code]

    #9508
    eadocX Support
    Keymaster

    I think I need a bit more than this if I’m going to look into this.
    What database? Do you have sample data you can send me ?

    #9509
    J Cullen
    Participant

    I have narrowed it down to a specific package and have been able to replicate the problem in a new model.
    It happens every time the package you analyse has an object in it and it has a classifier selected for that object.

    #9510
    eadocX Support
    Keymaster

    Might be an inconsistency in the EA model.
    Try exporting the package as XMI, deleting it in the model, and re-importing.

    #9511
    J Cullen
    Participant

    It also happens in a completely new .EAP file stored on my local desktop rather than any server database. It occurs with UML and SysML. You should be able to replicate it yourself by creating a class then creating an object as an instance of it.

    #9512
    J Cullen
    Participant

    I have attached an image of a diagram which model expert has this problem with.

    #9513
    J Cullen
    Participant

    Can you confirm that this is bug in Model Expert and it is intended to be fixed. Or that i am classifying objects incorrectly.

    #9514
    eadocX Support
    Keymaster

    Nothing you’re doing wrong – a bug in Model Expert 1.0 – this is fixed in 1.1, which I’m just finishing-off

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.

Compare pricing and features

Choose the eaDocX edition that’s right for you and your team

Compare Pricing

Download a free trial

Take a free, no obligation, 30-day trial of eaDocX. Discover for yourself why it’s the world’s best-selling Enterprise Architect extension.

Download